Missing permission check in Jenkins Implied Labels Plugin allows reconfiguring the plugin
CVE-2020-2282GHSA-5hw2-327v-vvr6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:implied-labels 0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:implied-labels
- Affected
- <= 0.6
- Fixed in
- 0.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5hw2-327v-vvr6 lists affected ranges: Maven org.jenkins-ci.plugins:implied-labels >=0 <=0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2020-2282: 0.66% estimated exploitation activity in the next 30 days; percentile 51.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Implied Labels Plugin 0.6 and earlier does not perform a permission check in an HTTP endpoint. This allows attackers with Overall/Read permission to configure the plugin. Implied Labels Plugin 0.7 requires Overall/Administer permission to configure the plugin.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5hw2-327v-vvr6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-2282 Advisory: Missing permission check in Jenkins Implied Labels Plugin allows reconfiguring the plugin IDs: CVE-2020-2282, GHSA-5hw2-327v-vvr6 Record: https://patchnext.com/advisories/cve-2020-2282 (revision 1, source checked 26 Oct 2026, 16:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:implied-labels 0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:implied-labels: affected <= 0.6; fixed in 0.7 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:implied-labels: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:implied-labels. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5hw2-327v-vvr6 (GitHub-reviewed advisory GHSA-5hw2-327v-vvr6 lists affected ranges: Maven org.jenkins-ci.plugins:implied-labels >=0 <=0.6) Commands are suggestions: review each one before running it.
Loading voting…