Improper Validation of Certificate with Host Mismatch in Jenkins Mailer Plugin
CVE-2020-2252GHSA-6fr3-286q-q3cr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:mailer 1.32.1, 1.31.1, 1.29.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:mailer
- Affected
- >= 1.32, <= 1.32>= 1.30, < 1.31.1< 1.29.1
- Fixed in
- 1.32.1, 1.31.1, 1.29.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6fr3-286q-q3cr lists affected ranges: Maven org.jenkins-ci.plugins:mailer >=1.32 =1.30 =0 <1.29.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2020-2252: 0.96% estimated exploitation activity in the next 30 days; percentile 61.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Mailer Plugin prior to 1.32.1, 1.31.1, and 1.29.1 does not perform hostname validation when connecting to the configured SMTP server. This lack of validation could be abused using a man-in-the-middle attack to intercept these connections. Mailer Plugin 1.32.1, 1.31.1, and 1.29.1 validates the SMTP hostname when connecting via TLS by default. In Mailer Plugin 1.32 and earlier, administrators can set the Java system property mail.smtp.ssl.checkserveridentity to true on startup to enable this protection. In case of problems, this protection can be disabled again by setting the Java system property mail.smtp.ssl.checkserveridentity to false on startup.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6fr3-286q-q3cr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-2252 Advisory: Improper Validation of Certificate with Host Mismatch in Jenkins Mailer Plugin IDs: CVE-2020-2252, GHSA-6fr3-286q-q3cr Record: https://patchnext.com/advisories/cve-2020-2252 (revision 1, source checked 26 Oct 2026, 16:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:mailer 1.32.1, 1.31.1, 1.29.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:mailer: affected >= 1.32, <= 1.32; >= 1.30, < 1.31.1; < 1.29.1; fixed in 1.32.1, 1.31.1, 1.29.1 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:mailer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:mailer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6fr3-286q-q3cr (GitHub-reviewed advisory GHSA-6fr3-286q-q3cr lists affected ranges: Maven org.jenkins-ci.plugins:mailer >=1.32 =1.30 =0 <1.29.1) Commands are suggestions: review each one before running it.
Loading voting…