Content-Security-Policy protection for user content disabled by Jenkins ZAP Pipeline Plugin
CVE-2020-2214GHSA-4c87-9xq5-5c35
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.vrondakis.zap:zap-pipeline 1.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.vrondakis.zap:zap-pipeline
- Affected
- < 1.10
- Fixed in
- 1.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4c87-9xq5-5c35 lists affected ranges: Maven com.vrondakis.zap:zap-pipeline >=0 <1.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2020-2214: 0.73% estimated exploitation activity in the next 30 days; percentile 54.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins sets the Content-Security-Policy header to static files served by Jenkins (specifically DirectoryBrowserSupport), such as workspaces, /userContent, or archived artifacts. ZAP Pipeline Plugin prior to 1.10 globally disables the Content-Security-Policy header for static files served by Jenkins. This allows cross-site scripting (XSS) attacks by users with the ability to control files in workspaces, archived artifacts, etc. Jenkins instances with Resource Root URL configured are largely unaffected. A possible exception are file parameter downloads. The behavior of those depends on the specific version of Jenkins: - Jenkins 2.231 and newer, including 2.235.x LTS, is unaffected, as all resource files from user content are generally served safely from a different domain, without restrictions from Content-Security-Policy header. - Jenkins between 2.228 (inclusive) and 2.230 (inclusive), as well as all releases of Jenkins 2.222.x LTS and the 2.204.6 LTS release, are affected by this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4c87-9xq5-5c35
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-2214 Advisory: Content-Security-Policy protection for user content disabled by Jenkins ZAP Pipeline Plugin IDs: CVE-2020-2214, GHSA-4c87-9xq5-5c35 Record: https://patchnext.com/advisories/cve-2020-2214 (revision 1, source checked 26 Oct 2026, 16:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.vrondakis.zap:zap-pipeline 1.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.vrondakis.zap:zap-pipeline: affected < 1.10; fixed in 1.10 ## Suggested inspection (read-only) - Maven com.vrondakis.zap:zap-pipeline: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.vrondakis.zap:zap-pipeline. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4c87-9xq5-5c35 (GitHub-reviewed advisory GHSA-4c87-9xq5-5c35 lists affected ranges: Maven com.vrondakis.zap:zap-pipeline >=0 <1.10) Commands are suggestions: review each one before running it.
Loading voting…