Skip to content

← Actionable
Critical, CVSS 9.8

NukeViet SQL Injection vulnerability

CVE-2020-21809GHSA-m8jx-mxf9-2rpw

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist nukeviet/nukeviet

    Affected
    >= 4.0, < 4.0.29>= 4.1, < 4.1.02>= 4.2, < 4.2.01>= 4.3, <= 4.3
    Fixed in
    4.1.02, 4.2.01, 4.0.29

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-21809: 1.58% estimated exploitation activity in the next 30 days; percentile 75.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

SQL Injection vulnerability in NukeViet CMS module Shops 4.0.29 and 4.3 via the (1) listid parameter in detail.php and the (2) groupprice or groupid parameters in searchresult.php. Fix Implementation: Download the update package corresponding to the NukeViet version you are using, extract and upload to hosting according to NukeViet's structure: For NukeViet 4.0 Official (4.0.29) For NukeViet 4.1 Official (4.1.02) For NukeViet 4.2 (4.2.01) As for NukeViet 4.3, you can update according to the notice in the admin page or see here: https://nukeviet.vn/vi/news/Tin-tuc/thong-bao-phat-hanh-nukeviet-4- 3-08-613.html

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m8jx-mxf9-2rpw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-21809

Advisory: NukeViet SQL Injection vulnerability
IDs: CVE-2020-21809, GHSA-m8jx-mxf9-2rpw
Record: https://patchnext.com/advisories/cve-2020-21809 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: nukeviet/nukeviet 4.2.01, 4.1.02, 4.0.29. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist nukeviet/nukeviet: affected >= 4.0, < 4.0.29; >= 4.1, < 4.1.02; >= 4.2, < 4.2.01; >= 4.3, <= 4.3; fixed in 4.1.02, 4.2.01, 4.0.29

## Suggested inspection (read-only)
- Packagist nukeviet/nukeviet: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nukeviet/nukeviet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m8jx-mxf9-2rpw (GitHub-reviewed advisory GHSA-m8jx-mxf9-2rpw lists affected ranges: Packagist nukeviet/nukeviet >=4.0 =4.1 =4.2 =4.3 <=4.3)

Commands are suggestions: review each one before running it.

Loading voting…