XXE vulnerability in Jenkins Cobertura Plugin
CVE-2020-2138GHSA-vpfj-5gg5-fvfm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:cobertura 1.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:cobertura
- Affected
- <= 1.15
- Fixed in
- 1.16
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vpfj-5gg5-fvfm lists affected ranges: Maven org.jenkins-ci.plugins:cobertura >=0 <=1.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2020-2138: 0.93% estimated exploitation activity in the next 30 days; percentile 60.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cobertura Plugin 1.15 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks. This allows a user able to control the input files for the 'Publish Cobertura Coverage Report' post-build step to have Jenkins parse a crafted file that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery. Cobertura Plugin 1.16 disables external entity resolution for its XML parser.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vpfj-5gg5-fvfm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-2138 Advisory: XXE vulnerability in Jenkins Cobertura Plugin IDs: CVE-2020-2138, GHSA-vpfj-5gg5-fvfm Record: https://patchnext.com/advisories/cve-2020-2138 (revision 1, source checked 26 Oct 2026, 16:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:cobertura 1.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:cobertura: affected <= 1.15; fixed in 1.16 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:cobertura: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:cobertura. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vpfj-5gg5-fvfm (GitHub-reviewed advisory GHSA-vpfj-5gg5-fvfm lists affected ranges: Maven org.jenkins-ci.plugins:cobertura >=0 <=1.15) Commands are suggestions: review each one before running it.
Loading voting…