Jenkins vulnerable to UDP amplification reflection attack
CVE-2020-2100GHSA-gpxv-776p-7gc7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.main:jenkins-core 2.219, 2.204.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.main:jenkins-core
- Affected
- < 2.204.2>= 2.205, < 2.219
- Fixed in
- 2.204.2, 2.219
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gpxv-776p-7gc7 lists affected ranges: Maven org.jenkins-ci.main:jenkins-core >=0 =2.205 <2.219
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L
- EPSS
- CVE-2020-2100: 3.44% estimated exploitation activity in the next 30 days; percentile 89.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins 2.218 and earlier, LTS 2.204.1 and earlier supports two network discovery services (UDP multicast/broadcast and DNS multicast) by default. The UDP multicast/broadcast service can be used in an amplification reflection attack, as very few bytes sent to the respective endpoint result in much larger responses: A single byte request to this service would respond with more than 100 bytes of Jenkins metadata which could be used in a DDoS attack on a Jenkins controller. Within the same network, spoofed UDP packets could also be sent to make two Jenkins controllers go into an infinite loop of replies to one another, thus causing a denial of service. Jenkins 2.219, LTS 2.204.2 now disables both UDP multicast/broadcast and DNS multicast by default. Administrators that need these features can re-enable them again by setting the system property hudson.DNSMultiCast.disabled to false (for DNS multicast) or the system property hudson.udp to 33848, or another port (for UDP…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gpxv-776p-7gc7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-2100 Advisory: Jenkins vulnerable to UDP amplification reflection attack IDs: CVE-2020-2100, GHSA-gpxv-776p-7gc7 Record: https://patchnext.com/advisories/cve-2020-2100 (revision 1, source checked 26 Oct 2026, 16:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.main:jenkins-core 2.219, 2.204.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.main:jenkins-core: affected < 2.204.2; >= 2.205, < 2.219; fixed in 2.204.2, 2.219 ## Suggested inspection (read-only) - Maven org.jenkins-ci.main:jenkins-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.main:jenkins-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gpxv-776p-7gc7 (GitHub-reviewed advisory GHSA-gpxv-776p-7gc7 lists affected ranges: Maven org.jenkins-ci.main:jenkins-core >=0 =2.205 <2.219) Commands are suggestions: review each one before running it.
Loading voting…