CSRF vulnerability in Health Advisor by CloudBees Plugin
CVE-2020-2093GHSA-fc92-8r77-9297
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:cloudbees-jenkins-advisor 3.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:cloudbees-jenkins-advisor
- Affected
- < 3.0.1
- Fixed in
- 3.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fc92-8r77-9297 lists affected ranges: Maven org.jenkins-ci.plugins:cloudbees-jenkins-advisor >=0 <3.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N
- EPSS
- CVE-2020-2093: 0.84% estimated exploitation activity in the next 30 days; percentile 58.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Health Advisor by CloudBees Plugin 3.0 and earlier does not perform permission checks in methods performing form validation. This allows users with Overall/Read access to send an email with fixed content to an attacker-specified recipient. Additionally, these form validation methods do not require POST requests, resulting in a CSRF vulnerability. Health Advisor by CloudBees Plugin 3.0.1 requires POST requests and Overall/Administer permission for the affected form validation methods.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fc92-8r77-9297
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-2093 Advisory: CSRF vulnerability in Health Advisor by CloudBees Plugin IDs: CVE-2020-2093, GHSA-fc92-8r77-9297 Record: https://patchnext.com/advisories/cve-2020-2093 (revision 1, source checked 26 Oct 2026, 16:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:cloudbees-jenkins-advisor 3.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:cloudbees-jenkins-advisor: affected < 3.0.1; fixed in 3.0.1 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:cloudbees-jenkins-advisor: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:cloudbees-jenkins-advisor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fc92-8r77-9297 (GitHub-reviewed advisory GHSA-fc92-8r77-9297 lists affected ranges: Maven org.jenkins-ci.plugins:cloudbees-jenkins-advisor >=0 <3.0.1) Commands are suggestions: review each one before running it.
Loading voting…