Missing permission checks in Jenkins Amazon EC2 Plugin
CVE-2020-2091GHSA-6hmm-77r2-h6hr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:ec2 1.48), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:ec2
- Affected
- < 1.48
- Fixed in
- 1.48
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6hmm-77r2-h6hr lists affected ranges: Maven org.jenkins-ci.plugins:ec2 >=0 <1.48
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2020-2091: 1.13% estimated exploitation activity in the next 30 days; percentile 66.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Amazon EC2 Plugin 1.47 and earlier does not perform permission checks in methods performing form validation. This allows users with Overall/Read access to Jenkins to connect to an attacker-specified URL within the AWS region using attacker-specified credentials IDs obtained through another method. This vulnerability might also allow attackers to capture credentials stored in Jenkins. We have not been able to confirm that this is possible. Additionally, these form validation methods do not require POST requests, resulting in a CSRF vulnerability. Amazon EC2 Plugin 1.48 requires POST requests and Overall/Administer permission for the affected form validation methods.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6hmm-77r2-h6hr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-2091 Advisory: Missing permission checks in Jenkins Amazon EC2 Plugin IDs: CVE-2020-2091, GHSA-6hmm-77r2-h6hr Record: https://patchnext.com/advisories/cve-2020-2091 (revision 1, source checked 26 Oct 2026, 16:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:ec2 1.48. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:ec2: affected < 1.48; fixed in 1.48 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:ec2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:ec2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6hmm-77r2-h6hr (GitHub-reviewed advisory GHSA-6hmm-77r2-h6hr lists affected ranges: Maven org.jenkins-ci.plugins:ec2 >=0 <1.48) Commands are suggestions: review each one before running it.
Loading voting…