Directus API vulnerable to denial of service
CVE-2020-19850GHSA-3gvp-54v2-2jrp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 2.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm directus
- Affected
- >= 2.2.0, <= 2.2.0
- Fixed in
- 2.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3gvp-54v2-2jrp lists affected ranges: npm directus >=2.2.0 <2.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3gvp-54v2-2jrp lists affected ranges: npm directus >=2.2.0 <=2.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2020-19850: 1.08% estimated exploitation activity in the next 30 days; percentile 65.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue found in Directus API v.2.2.0 allows a remote attacker to cause a denial of service via a great amount of HTTP requests.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3gvp-54v2-2jrp
- Revision 1 · created ·
Published from osv record GHSA-3gvp-54v2-2jrp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-19850 Advisory: Directus API vulnerable to denial of service IDs: CVE-2020-19850, GHSA-3gvp-54v2-2jrp Record: https://patchnext.com/advisories/cve-2020-19850 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: directus 2.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm directus: affected >= 2.2.0, <= 2.2.0; fixed in 2.2.1 ## Suggested inspection (read-only) - `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on directus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3gvp-54v2-2jrp (OSV record GHSA-3gvp-54v2-2jrp lists affected ranges: npm directus >=2.2.0 <2.2.1 (fixed)) - Verified: https://github.com/advisories/GHSA-3gvp-54v2-2jrp (GitHub-reviewed advisory GHSA-3gvp-54v2-2jrp lists affected ranges: npm directus >=2.2.0 <=2.2.0) Commands are suggestions: review each one before running it.
Loading voting…