Skip to content

← Actionable
Medium, CVSS 6.5

Credentials bypass in Apache Druid

CVE-2020-1958GHSA-qh2g-7h5p-mxf4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.druid:druid 0.17.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2020-1958: 4.57% estimated exploitation activity in the next 30 days; percentile 91.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When LDAP authentication is enabled in Apache Druid 0.17.0, callers of Druid APIs with a valid set of LDAP credentials can bypass the credentialsValidator.userSearch filter barrier that determines if a valid LDAP user is allowed to authenticate with Druid. They are still subject to role-based authorization checks, if configured. Callers of Druid APIs can also retrieve any LDAP attribute values of users that exist on the LDAP server, so long as that information is visible to the Druid server. This information disclosure does not require the caller itself to be a valid LDAP user.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qh2g-7h5p-mxf4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-1958

Advisory: Credentials bypass in Apache Druid
IDs: CVE-2020-1958, GHSA-qh2g-7h5p-mxf4
Record: https://patchnext.com/advisories/cve-2020-1958 (revision 1, source checked 26 Oct 2026, 16:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.druid:druid 0.17.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.druid:druid: affected >= 0.17.0, <= 0.17.0; fixed in 0.17.1

## Suggested inspection (read-only)
- Maven org.apache.druid:druid: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.druid:druid.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qh2g-7h5p-mxf4 (GitHub-reviewed advisory GHSA-qh2g-7h5p-mxf4 lists affected ranges: Maven org.apache.druid:druid >=0.17.0 <=0.17.0)

Commands are suggestions: review each one before running it.

Loading voting…