Improper Privilege Management in Tomcat
CVE-2020-1938GHSA-c9hw-wf7x-jp9j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat.embed:tomcat-embed-core 9.0.31, 8.5.51, 7.0.100), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 9.0.0, < 9.0.31>= 8.0.0, < 8.5.51>= 7.0.0, < 7.0.100
- Fixed in
- 9.0.31, 8.5.51, 7.0.100
Sources
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2020-1938 to the Known Exploited Vulnerabilities catalog on 2022-03-03.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2022-03-03).
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c9hw-wf7x-jp9j lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=9.0.0 =8.0.0 =7.0.0 <7.0.100
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
- EPSS
- CVE-2020-1938: 99.27% estimated exploitation activity in the next 30 days; percentile 99.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When using the Apache JServ Protocol (AJP), care must be taken when trusting incoming connections to Apache Tomcat. Tomcat treats AJP connections as having higher trust than, for example, a similar HTTP connection. If such connections are available to an attacker, they can be exploited in ways that may be surprising. In Apache Tomcat 9.0.0.M1 to 9.0.0.30, 8.5.0 to 8.5.50 and 7.0.0 to 7.0.99, Tomcat shipped with an AJP Connector enabled by default that listened on all configured IP addresses. It was expected (and recommended in the security guide) that this Connector would be disabled if not required. This vulnerability report identified a mechanism that allowed: returning arbitrary files from anywhere in the web application, processing any file in the web application as a JSP Further, if the web application allowed file upload and stored those files within the web application (or the attacker was able to control the content of the web application by some other means) then this, along…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c9hw-wf7x-jp9j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-1938 Advisory: Improper Privilege Management in Tomcat IDs: CVE-2020-1938, GHSA-c9hw-wf7x-jp9j Record: https://patchnext.com/advisories/cve-2020-1938 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat.embed:tomcat-embed-core 9.0.31, 8.5.51, 7.0.100. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 9.0.0, < 9.0.31; >= 8.0.0, < 8.5.51; >= 7.0.0, < 7.0.100; fixed in 9.0.31, 8.5.51, 7.0.100 ## Suggested inspection (read-only) - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat.embed:tomcat-embed-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2020-1938 to the Known Exploited Vulnerabilities catalog on 2022-03-03.) - Verified: https://github.com/advisories/GHSA-c9hw-wf7x-jp9j (GitHub-reviewed advisory GHSA-c9hw-wf7x-jp9j lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=9.0.0 =8.0.0 =7.0.0 <7.0.100) Commands are suggestions: review each one before running it.
Loading voting…