Skip to content

← Actionable
High, CVSS 7.5amended

Regular expression denial of service in react-native

CVE-2020-1920GHSA-7f53-fmmv-mfjv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (react-native 0.64.1, 0.62.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm react-native

    Affected
    >= 0.59.0, < 0.62.3>= 0.63.0, < 0.64.1
    Fixed in
    0.64.1, 0.62.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2020-1920: 1.36% estimated exploitation activity in the next 30 days; percentile 71.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A regular expression denial of service (ReDoS) vulnerability in the validateBaseUrl function can cause the application to use excessive resources, become unresponsive, or crash. This was introduced in react-native version 0.59.0 and fixed in version 0.64.1.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7f53-fmmv-mfjv

  2. Revision 1 · created ·

    Published from osv record GHSA-7f53-fmmv-mfjv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-1920

Advisory: Regular expression denial of service in react-native
IDs: CVE-2020-1920, GHSA-7f53-fmmv-mfjv
Record: https://patchnext.com/advisories/cve-2020-1920 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: react-native 0.64.1, 0.62.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm react-native: affected >= 0.59.0, < 0.62.3; >= 0.63.0, < 0.64.1; fixed in 0.64.1, 0.62.3

## Suggested inspection (read-only)
- `npm ls react-native --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on react-native.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7f53-fmmv-mfjv (OSV record GHSA-7f53-fmmv-mfjv lists affected ranges: npm react-native >=0.59.0 =0.63.0 <0.64.1 (fixed))
- Verified: https://github.com/advisories/GHSA-7f53-fmmv-mfjv (GitHub-reviewed advisory GHSA-7f53-fmmv-mfjv lists affected ranges: npm react-native >=0.59.0 =0.63.0 <0.64.1)

Commands are suggestions: review each one before running it.

Loading voting…