Skip to content

← Actionable
Critical, CVSS 9.8amended

Always-Incorrect Control Flow Implementation in Facebook Hermes

CVE-2020-1914GHSA-327c-qx3v-h673

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (hermes-engine 0.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-1914: 2.51% estimated exploitation activity in the next 30 days; percentile 84.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A logic vulnerability when handling the SaveGeneratorLong instruction in Facebook Hermes prior to commit b2021df620824627f5a8c96615edbd1eb7fdddfc allows attackers to potentially read out of bounds or theoretically execute arbitrary code via crafted JavaScript. Note that this is only exploitable if the application using Hermes permits evaluation of untrusted JavaScript. Hence, most React Native applications are not affected.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-327c-qx3v-h673

  2. Revision 1 · created ·

    Published from osv record GHSA-327c-qx3v-h673

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-1914

Advisory: Always-Incorrect Control Flow Implementation in Facebook Hermes
IDs: CVE-2020-1914, GHSA-327c-qx3v-h673
Record: https://patchnext.com/advisories/cve-2020-1914 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: hermes-engine 0.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm hermes-engine: affected <= 0.7.1; fixed in 0.7.2

## Suggested inspection (read-only)
- `npm ls hermes-engine --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on hermes-engine.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-327c-qx3v-h673 (OSV record GHSA-327c-qx3v-h673 lists affected ranges: npm hermes-engine >=0 <0.7.2 (fixed))
- Verified: https://github.com/advisories/GHSA-327c-qx3v-h673 (GitHub-reviewed advisory GHSA-327c-qx3v-h673 lists affected ranges: npm hermes-engine >=0 <=0.7.1)

Commands are suggestions: review each one before running it.

Loading voting…