Out-of-bounds Read and Out-of-bounds Write in Facebook Hermes
CVE-2020-1912GHSA-pf27-929j-9pmm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (hermes-engine 0.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm hermes-engine
- Affected
- <= 0.4.3
- Fixed in
- 0.5.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pf27-929j-9pmm lists affected ranges: npm hermes-engine >=0 <0.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pf27-929j-9pmm lists affected ranges: npm hermes-engine >=0 <=0.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-1912: 1.81% estimated exploitation activity in the next 30 days; percentile 78.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An out-of-bounds read/write vulnerability when executing lazily compiled inner generator functions in Facebook Hermes prior to commit 091835377369c8fd5917d9b87acffa721ad2a168 allows attackers to potentially execute arbitrary code via crafted JavaScript. Note that this is only exploitable if the application using Hermes permits evaluation of untrusted JavaScript. Hence, most React Native applications are not affected.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pf27-929j-9pmm
- Revision 1 · created ·
Published from osv record GHSA-pf27-929j-9pmm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-1912 Advisory: Out-of-bounds Read and Out-of-bounds Write in Facebook Hermes IDs: CVE-2020-1912, GHSA-pf27-929j-9pmm Record: https://patchnext.com/advisories/cve-2020-1912 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: hermes-engine 0.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm hermes-engine: affected <= 0.4.3; fixed in 0.5.2 ## Suggested inspection (read-only) - `npm ls hermes-engine --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on hermes-engine. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pf27-929j-9pmm (OSV record GHSA-pf27-929j-9pmm lists affected ranges: npm hermes-engine >=0 <0.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-pf27-929j-9pmm (GitHub-reviewed advisory GHSA-pf27-929j-9pmm lists affected ranges: npm hermes-engine >=0 <=0.4.3) Commands are suggestions: review each one before running it.
Loading voting…