Cross-site scripting (XSS)
CVE-2020-17551GHSA-j29g-g982-pwpv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (impresscms/impresscms 1.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist impresscms/impresscms
- Affected
- <= 1.4.0
- Fixed in
- 1.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j29g-g982-pwpv lists affected ranges: Packagist impresscms/impresscms >=0 <=1.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2020-17551: 1.13% estimated exploitation activity in the next 30 days; percentile 66.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
ImpressCMS 1.4.0 is affected by XSS in modules/system/admin.php which may result in arbitrary remote code execution.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j29g-g982-pwpv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-17551 Advisory: Cross-site scripting (XSS) IDs: CVE-2020-17551, GHSA-j29g-g982-pwpv Record: https://patchnext.com/advisories/cve-2020-17551 (revision 1, source checked 26 Oct 2026, 14:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: impresscms/impresscms 1.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist impresscms/impresscms: affected <= 1.4.0; fixed in 1.4.1 ## Suggested inspection (read-only) - Packagist impresscms/impresscms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on impresscms/impresscms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j29g-g982-pwpv (GitHub-reviewed advisory GHSA-j29g-g982-pwpv lists affected ranges: Packagist impresscms/impresscms >=0 <=1.4.0) Commands are suggestions: review each one before running it.
Loading voting…