Skip to content

← Actionable
Medium, CVSS 6.8amended

Insertion of Sensitive Information into Log File, Invocation of Process Using Visible Sensitive Information, and Exposure of Sensitive Information to an Unauthorized Actor in Ansible

CVE-2020-1753GHSA-86hp-cj9j-33vv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ansible 2.9.7, 2.8.12, 2.7.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ansible

    Affected
    >= 2.7.0a1, < 2.7.18>= 2.8.0a1, < 2.8.12>= 2.9.0a1, < 2.9.7
    Fixed in
    2.9.7, 2.7.18, 2.8.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2020-1753: 0.51% estimated exploitation activity in the next 30 days; percentile 43.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A security flaw was found in Ansible Engine, all Ansible 2.7.x versions prior to 2.7.17, all Ansible 2.8.x versions prior to 2.8.11 and all Ansible 2.9.x versions prior to 2.9.7, when managing kubernetes using the k8s module. Sensitive parameters such as passwords and tokens are passed to kubectl from the command line, not using an environment variable or an input configuration file. This will disclose passwords and tokens from process list and nolog directive from debug module would not have any effect making these secrets being disclosed on stdout and log files.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-86hp-cj9j-33vv

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-86hp-cj9j-33vv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-1753

Advisory: Insertion of Sensitive Information into Log File, Invocation of Process Using Visible Sensitive Information, and Exposure of Sensitive Information to an Unauthorized Actor in Ansible
IDs: CVE-2020-1753, GHSA-86hp-cj9j-33vv
Record: https://patchnext.com/advisories/cve-2020-1753 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ansible 2.9.7, 2.8.12, 2.7.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ansible: affected >= 2.7.0a1, < 2.7.18; >= 2.8.0a1, < 2.8.12; >= 2.9.0a1, < 2.9.7; fixed in 2.9.7, 2.7.18, 2.8.12

## Suggested inspection (read-only)
- `python -m pip show ansible`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ansible.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-86hp-cj9j-33vv (OSV record GHSA-86hp-cj9j-33vv lists affected ranges: PyPI ansible >=2.7.0a1 =2.8.0a1 =2.9.0a1 <2.9.7 (fixed))
- Verified: https://github.com/advisories/GHSA-86hp-cj9j-33vv (GitHub-reviewed advisory GHSA-86hp-cj9j-33vv lists affected ranges: PyPI ansible >=2.7.0a1 =2.8.0a1 =2.9.0a1 <2.9.7)

Commands are suggestions: review each one before running it.

Loading voting…