Keycloak Insufficient Session Expiry
CVE-2020-1724GHSA-8xj2-47xw-q78c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.keycloak:keycloak-core 9.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.keycloak:keycloak-core
- Affected
- < 9.0.2
- Fixed in
- 9.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8xj2-47xw-q78c lists affected ranges: Maven org.keycloak:keycloak-core >=0 <9.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2020-1724: 0.82% estimated exploitation activity in the next 30 days; percentile 57.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in Keycloak in versions before 9.0.2. This flaw allows a malicious user that is currently logged in, to see the personal information of a previously logged out user in the account manager section.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8xj2-47xw-q78c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-1724 Advisory: Keycloak Insufficient Session Expiry IDs: CVE-2020-1724, GHSA-8xj2-47xw-q78c Record: https://patchnext.com/advisories/cve-2020-1724 (revision 1, source checked 26 Oct 2026, 16:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.keycloak:keycloak-core 9.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.keycloak:keycloak-core: affected < 9.0.2; fixed in 9.0.2 ## Suggested inspection (read-only) - Maven org.keycloak:keycloak-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.keycloak:keycloak-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8xj2-47xw-q78c (GitHub-reviewed advisory GHSA-8xj2-47xw-q78c lists affected ranges: Maven org.keycloak:keycloak-core >=0 <9.0.2) Commands are suggestions: review each one before running it.
Loading voting…