Cross-site Scripting vulnerability in Kitodo.Presentation
CVE-2020-16095GHSA-fpqv-x9hm-35j9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (kitodo/presentation 3.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist kitodo/presentation
- Affected
- < 3.1.2
- Fixed in
- 3.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fpqv-x9hm-35j9 lists affected ranges: Packagist kitodo/presentation >=0 <3.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2020-16095: 0.87% estimated exploitation activity in the next 30 days; percentile 58.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Kitodo.Presentation fails to properly encode URL parameters for output in HTML making it vulnerable to Cross Site Scripting (XSS). Only sites using the ListView, Navigation or PageView plugins are affected. It also includes jQuery 3.4.1 which is known to be vulnerable against Cross Site Scripting, although there is currently no known way to exploit this in Kitodo.Presentation. Patches An updated version of Kitodo.Presentation is available on GitHub, Packagist and in the TYPO3 Extension Repository. Users are advised to update as soon as possible. The issue was also fixed in release 2.3.1 of the 2.x branch, although it is generally not recommended to run this branch since it depends on an outdated TYPO3 version. References TYPO3 Security Advisory TYPO3-EXT-SA-2020-015 jQuery Security Advisory GHSA-gxr4-xjj5-5px2 Open Bug Bounty Report OBB-1219978 Contact If you have any questions or comments about this advisory: Open an issue Email us at security@kitodo.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fpqv-x9hm-35j9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-16095 Advisory: Cross-site Scripting vulnerability in Kitodo.Presentation IDs: CVE-2020-16095, GHSA-fpqv-x9hm-35j9 Record: https://patchnext.com/advisories/cve-2020-16095 (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: kitodo/presentation 3.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist kitodo/presentation: affected < 3.1.2; fixed in 3.1.2 ## Suggested inspection (read-only) - Packagist kitodo/presentation: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on kitodo/presentation. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fpqv-x9hm-35j9 (GitHub-reviewed advisory GHSA-fpqv-x9hm-35j9 lists affected ranges: Packagist kitodo/presentation >=0 <3.1.2) Commands are suggestions: review each one before running it.
Loading voting…