Skip to content

← Actionable
High, CVSS 8.5amended

bsdiff4 out-of-bounds write via patch file

CVE-2020-15904GHSA-f8m3-jpxr-hm5x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bsdiff4 1.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI bsdiff4

    Affected
    < 1.2.0
    Fixed in
    1.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2020-15904: 1.05% estimated exploitation activity in the next 30 days; percentile 64.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A buffer overflow in the patching routine of bsdiff4 before 1.2.0 allows an attacker to write to heap memory (beyond allocated bounds) via a crafted patch file.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-f8m3-jpxr-hm5x

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-f8m3-jpxr-hm5x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15904

Advisory: bsdiff4 out-of-bounds write via patch file
IDs: CVE-2020-15904, GHSA-f8m3-jpxr-hm5x
Record: https://patchnext.com/advisories/cve-2020-15904 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bsdiff4 1.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI bsdiff4: affected < 1.2.0; fixed in 1.2.0

## Suggested inspection (read-only)
- `python -m pip show bsdiff4`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bsdiff4.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f8m3-jpxr-hm5x (OSV record GHSA-f8m3-jpxr-hm5x lists affected ranges: PyPI bsdiff4 >=0 <1.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-f8m3-jpxr-hm5x (GitHub-reviewed advisory GHSA-f8m3-jpxr-hm5x lists affected ranges: PyPI bsdiff4 >=0 <1.2.0)

Commands are suggestions: review each one before running it.

Loading voting…