MunkiReport reportdata module SQL injection vulnerability
CVE-2020-15886GHSA-qvw9-6567-wq78
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (munkireport/reportdata 3.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist munkireport/reportdata
- Affected
- < 3.5
- Fixed in
- 3.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qvw9-6567-wq78 lists affected ranges: Packagist munkireport/reportdata >=0 <3.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-15886: 1.26% estimated exploitation activity in the next 30 days; percentile 69.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A SQL injection vulnerability in reportdatacontroller.php in the reportdata module before 3.5 for MunkiReport allows attackers to execute arbitrary SQL commands via the req parameter of the /module/reportdata/ip endpoint.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qvw9-6567-wq78
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-15886 Advisory: MunkiReport reportdata module SQL injection vulnerability IDs: CVE-2020-15886, GHSA-qvw9-6567-wq78 Record: https://patchnext.com/advisories/cve-2020-15886 (revision 1, source checked 26 Oct 2026, 14:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: munkireport/reportdata 3.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist munkireport/reportdata: affected < 3.5; fixed in 3.5 ## Suggested inspection (read-only) - Packagist munkireport/reportdata: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on munkireport/reportdata. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qvw9-6567-wq78 (GitHub-reviewed advisory GHSA-qvw9-6567-wq78 lists affected ranges: Packagist munkireport/reportdata >=0 <3.5) Commands are suggestions: review each one before running it.
Loading voting…