Skip to content

← Actionable
Medium, CVSS 4.0amended

aptdaemon Information Disclosure via Improper Input Validation in Transaction class

CVE-2020-15703GHSA-wpmr-q825-x4c6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aptdaemon 1.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.0 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2020-15703: 0.49% estimated exploitation activity in the next 30 days; percentile 42.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There is no input validation on the Locale property in an apt transaction. An unprivileged user can supply a full path to a writable directory, which lets aptd read a file as root. Having a symlink in place results in an error message if the file exists, and no error otherwise. This way an unprivileged user can check for the existence of any files on the system as root.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wpmr-q825-x4c6

  2. Revision 1 · created ·

    Published from osv record GHSA-wpmr-q825-x4c6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15703

Advisory: aptdaemon Information Disclosure via Improper Input Validation in Transaction class
IDs: CVE-2020-15703, GHSA-wpmr-q825-x4c6
Record: https://patchnext.com/advisories/cve-2020-15703 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aptdaemon 1.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI aptdaemon: affected < 1.1.1; fixed in 1.1.1

## Suggested inspection (read-only)
- `python -m pip show aptdaemon`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aptdaemon.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wpmr-q825-x4c6 (OSV record GHSA-wpmr-q825-x4c6 lists affected ranges: PyPI aptdaemon >=0 <1.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-wpmr-q825-x4c6 (GitHub-reviewed advisory GHSA-wpmr-q825-x4c6 lists affected ranges: PyPI aptdaemon >=0 <1.1.1)

Commands are suggestions: review each one before running it.

Loading voting…