Unauthorized privilege escalation in Mod module
CVE-2020-15278GHSA-mp9m-g7qj-6vqr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (red-discordbot 3.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI red-discordbot
- Affected
- < 3.4.1
- Fixed in
- 3.4.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mp9m-g7qj-6vqr lists affected ranges: PyPI red-discordbot >=0 <3.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mp9m-g7qj-6vqr lists affected ranges: PyPI red-discordbot >=0 <3.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N · score source
- EPSS
- CVE-2020-15278: 1.09% estimated exploitation activity in the next 30 days; percentile 65.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An unauthorized privilege escalation exploit has been discovered in the Mod module: this exploit allows Discord users with a high privilege level within the guild to bypass hierarchy checks when the application is in a specific condition that is beyond that user's control. By abusing this exploit, it's possible to perform destructive actions within the guild the user has high privileges in. Patches This exploit has been fixed on version & 3.4.1. Workarounds Unloading the Mod module with unload mod or, disabling the massban command with command disable global massban can render this exploit not accessible. We still highly recommend updating to 3.4.1 to completely patch this issue. References https://github.com/Cog-Creators/Red-DiscordBot/commit/726bfd38adfdfaef760412a68e01447b470f438b For more information If you have any questions or comments about this advisory: Open an issue in Cog-Creators/Red-DiscordBot Over on our Discord server
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mp9m-g7qj-6vqr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mp9m-g7qj-6vqr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-15278 Advisory: Unauthorized privilege escalation in Mod module IDs: CVE-2020-15278, GHSA-mp9m-g7qj-6vqr Record: https://patchnext.com/advisories/cve-2020-15278 (revision 3, source checked 26 Oct 2026, 13:23 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: red-discordbot 3.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI red-discordbot: affected < 3.4.1; fixed in 3.4.1 ## Suggested inspection (read-only) - `python -m pip show red-discordbot`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on red-discordbot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mp9m-g7qj-6vqr (OSV record GHSA-mp9m-g7qj-6vqr lists affected ranges: PyPI red-discordbot >=0 <3.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-mp9m-g7qj-6vqr (GitHub-reviewed advisory GHSA-mp9m-g7qj-6vqr lists affected ranges: PyPI red-discordbot >=0 <3.4.1) Commands are suggestions: review each one before running it.
Loading voting…