Skip to content

← Actionable
Critical, CVSS 9.3amended

Markdown-supplied Shell Command Execution

CVE-2020-15271GHSA-c84h-w6cr-5v8q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lookatme 2.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI lookatme

    Affected
    < 2.3.0
    Fixed in
    2.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N · score source
EPSS
  • CVE-2020-15271: 2.31% estimated exploitation activity in the next 30 days; percentile 83.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact lookatme versions prior to 2.3.0 automatically loaded the built-in "terminal" and "fileloader" extensions. Users that use lookatme to render untrusted markdown may have malicious shell commands automatically run on their system. Patches Users should upgrade to lookatme versions 2.3.0 or above. Workarounds The lookatme/contrib/terminal.py and lookatme/contrib/fileloader.py files may be manually deleted. Additionally, it is always recommended to be aware of what is being rendered with lookatme. References https://github.com/d0c-s4vage/lookatme/pull/110 https://github.com/d0c-s4vage/lookatme/releases/tag/v2.3.0 For more information If you have any questions or comments about this advisory: Open an issue in d0c-s4vage/lookatme

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c84h-w6cr-5v8q

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-c84h-w6cr-5v8q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15271

Advisory: Markdown-supplied Shell Command Execution
IDs: CVE-2020-15271, GHSA-c84h-w6cr-5v8q
Record: https://patchnext.com/advisories/cve-2020-15271 (revision 3, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lookatme 2.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI lookatme: affected < 2.3.0; fixed in 2.3.0

## Suggested inspection (read-only)
- `python -m pip show lookatme`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lookatme.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c84h-w6cr-5v8q (OSV record GHSA-c84h-w6cr-5v8q lists affected ranges: PyPI lookatme >=0 <2.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-c84h-w6cr-5v8q (GitHub-reviewed advisory GHSA-c84h-w6cr-5v8q lists affected ranges: PyPI lookatme >=0 <2.3.0)

Commands are suggestions: review each one before running it.

Loading voting…