Skip to content

← Actionable
Medium, CVSS 4.3amended

receiving subscription objects with deleted session

CVE-2020-15270GHSA-2xm2-xj2q-qgpj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 4.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2020-15270: 1.17% estimated exploitation activity in the next 30 days; percentile 67.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Original Message: Hi, I create objects with one client with an ACL of all users with a specific column value. Thats working so far. Then I deleted the session object from one user to look if he can receive subscription objects and he can receive them. The client with the deleted session cant create new objects, which Parse restricts right. The LiveQueryServer doesnt detect deleted sessions after the websocket connection was established. There should be a mechanism that checks in an specific interval if the session exists. I dont know if its true with expired sessions. Any solutions? Parse version: 4.3.0 Parse js SDK version: 2.17 Solution: Hi guys. I've found and fixed the problem. It happens because there are two caches in place for the session token: - at Parse Server level, which, according with the docs, should be changed via cacheTTL option and defaults to 5 seconds; - at Parse Live Query level, which, according with the docs, should be changed via…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2xm2-xj2q-qgpj

  2. Revision 1 · created ·

    Published from osv record GHSA-2xm2-xj2q-qgpj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15270

Advisory: receiving subscription objects with deleted session
IDs: CVE-2020-15270, GHSA-2xm2-xj2q-qgpj
Record: https://patchnext.com/advisories/cve-2020-15270 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 4.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected < 4.4.0; fixed in 4.4.0

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2xm2-xj2q-qgpj (OSV record GHSA-2xm2-xj2q-qgpj lists affected ranges: npm parse-server >=0 <4.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-2xm2-xj2q-qgpj (GitHub-reviewed advisory GHSA-2xm2-xj2q-qgpj lists affected ranges: npm parse-server >=0 <4.4.0)

Commands are suggestions: review each one before running it.

Loading voting…