Skip to content

← Actionable
Medium, CVSS 6.3amended

Float cast overflow undefined behavior

CVE-2020-15266GHSA-xwhf-g6j5-j5gc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.4.0; tensorflow-gpu 2.4.0; tensorflow-cpu 2.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2020-15266: 0.94% estimated exploitation activity in the next 30 days; percentile 60.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When the boxes argument of tf.image.cropandresize has a very large value, the CPU kernel implementation receives it as a C++ nan floating point value. Attempting to operate on this is undefined behavior which later produces a segmentation fault. Patches We have patched the issue in c0319231333f0f16e1cc75ec83660b01fedd4182 and will release TensorFlow 2.4.0 containing the patch. TensorFlow nightly packages after this commit will also have the issue resolved. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability has been reported in #42129

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xwhf-g6j5-j5gc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-xwhf-g6j5-j5gc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15266

Advisory: Float cast overflow undefined behavior
IDs: CVE-2020-15266, GHSA-xwhf-g6j5-j5gc
Record: https://patchnext.com/advisories/cve-2020-15266 (revision 3, source checked 26 Oct 2026, 13:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.4.0; tensorflow-gpu 2.4.0; tensorflow-cpu 2.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected < 2.4.0; fixed in 2.4.0
- PyPI tensorflow-gpu: affected < 2.4.0; fixed in 2.4.0
- PyPI tensorflow-cpu: affected < 2.4.0; fixed in 2.4.0

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xwhf-g6j5-j5gc (OSV record GHSA-xwhf-g6j5-j5gc lists affected ranges: PyPI tensorflow >=0 =0 =0 <2.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-xwhf-g6j5-j5gc (GitHub-reviewed advisory GHSA-xwhf-g6j5-j5gc lists affected ranges: PyPI tensorflow >=0 =0 =0 <2.4.0)

Commands are suggestions: review each one before running it.

Loading voting…