Segfault in tf.quantization.quantize_and_dequantize
CVE-2020-15265GHSA-rrfp-j2mp-hq9c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.4.0; tensorflow-gpu 2.4.0; tensorflow-cpu 2.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tensorflow
- Affected
- < 2.4.0
- Fixed in
- 2.4.0
PyPI tensorflow-gpu
- Affected
- < 2.4.0
- Fixed in
- 2.4.0
PyPI tensorflow-cpu
- Affected
- < 2.4.0
- Fixed in
- 2.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rrfp-j2mp-hq9c lists affected ranges: PyPI tensorflow >=0 =0 =0 <2.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rrfp-j2mp-hq9c lists affected ranges: PyPI tensorflow >=0 =0 =0 <2.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2020-15265: 0.91% estimated exploitation activity in the next 30 days; percentile 59.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker can pass an invalid axis value to tf.quantization.quantizeanddequantize: This results in accessing a dimension outside the rank of the input tensor in the C++ kernel implementation: However, dimsize only does a DCHECK to validate the argument and then uses it to access the corresponding element of an array: Since in normal builds, DCHECK-like macros are no-ops, this results in segfault and access out of bounds of the array. Patches We have patched the issue in eccb7ec454e6617738554a255d77f08e60ee0808 and will release TensorFlow 2.4.0 containing the patch. TensorFlow nightly packages after this commit will also have the issue resolved. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability has been reported in #42105
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rrfp-j2mp-hq9c
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-rrfp-j2mp-hq9c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-15265 Advisory: Segfault in `tf.quantization.quantize_and_dequantize` IDs: CVE-2020-15265, GHSA-rrfp-j2mp-hq9c Record: https://patchnext.com/advisories/cve-2020-15265 (revision 3, source checked 26 Oct 2026, 13:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.4.0; tensorflow-gpu 2.4.0; tensorflow-cpu 2.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tensorflow: affected < 2.4.0; fixed in 2.4.0 - PyPI tensorflow-gpu: affected < 2.4.0; fixed in 2.4.0 - PyPI tensorflow-cpu: affected < 2.4.0; fixed in 2.4.0 ## Suggested inspection (read-only) - `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rrfp-j2mp-hq9c (OSV record GHSA-rrfp-j2mp-hq9c lists affected ranges: PyPI tensorflow >=0 =0 =0 <2.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-rrfp-j2mp-hq9c (GitHub-reviewed advisory GHSA-rrfp-j2mp-hq9c lists affected ranges: PyPI tensorflow >=0 =0 =0 <2.4.0) Commands are suggestions: review each one before running it.
Loading voting…