Skip to content

← Actionable
Low, CVSS 3.7amended

Unprotected dynamically loaded chunks

CVE-2020-15262GHSA-4fc4-chg7-h8gh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (webpack-subresource-integrity 1.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2020-15262: 0.52% estimated exploitation activity in the next 30 days; percentile 44.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact All dynamically loaded chunks receive an invalid integrity hash that is ignored by the browser, and therefore the browser cannot validate their integrity. This removes the additional level of protection offered by SRI for such chunks. Top-level chunks are unaffected. Patches This issue is patched in version 1.5.1. Workarounds N/A References https://github.com/waysact/webpack-subresource-integrity/issues/131 For more information If you have any questions or comments about this advisory: Comment on webpack-subresource-integrity issue #131 Or email us at security@waysact.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4fc4-chg7-h8gh

  2. Revision 1 · created ·

    Published from osv record GHSA-4fc4-chg7-h8gh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15262

Advisory: Unprotected dynamically loaded chunks
IDs: CVE-2020-15262, GHSA-4fc4-chg7-h8gh
Record: https://patchnext.com/advisories/cve-2020-15262 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: webpack-subresource-integrity 1.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm webpack-subresource-integrity: affected < 1.5.1; fixed in 1.5.1

## Suggested inspection (read-only)
- `npm ls webpack-subresource-integrity --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on webpack-subresource-integrity.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4fc4-chg7-h8gh (OSV record GHSA-4fc4-chg7-h8gh lists affected ranges: npm webpack-subresource-integrity >=0 <1.5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-4fc4-chg7-h8gh (GitHub-reviewed advisory GHSA-4fc4-chg7-h8gh lists affected ranges: npm webpack-subresource-integrity >=0 <1.5.1)

Commands are suggestions: review each one before running it.

Loading voting…