Skip to content

← Actionable
Medium, CVSS 5.2

containerd-shim API Exposed to Host Network Containers

CVE-2020-15257GHSA-36xw-fx78-c5r4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/containerd/containerd 1.4.3, 1.3.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.2 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
EPSS
  • CVE-2020-15257: 3.13% estimated exploitation activity in the next 30 days; percentile 87.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Access controls for the shim’s API socket verified that the connecting process had an effective UID of 0, but did not otherwise restrict access to the abstract Unix domain socket. This would allow malicious containers running in the same network namespace as the shim, with an effective UID of 0 but otherwise reduced privileges, to cause new processes to be run with elevated privileges. Specific Go Packages Affected github.com/containerd/containerd/cmd Patches This vulnerability has been fixed in containerd 1.3.9 and 1.4.3. Users should update to these versions as soon as they are released. It should be noted that containers started with an old version of containerd-shim should be stopped and restarted, as running containers will continue to be vulnerable even after an upgrade. Workarounds If you are not providing the ability for untrusted users to start containers in the same network namespace as the shim (typically the "host" network namespace, for example with docker run…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-36xw-fx78-c5r4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15257

Advisory: containerd-shim API Exposed to Host Network Containers
IDs: CVE-2020-15257, GHSA-36xw-fx78-c5r4
Record: https://patchnext.com/advisories/cve-2020-15257 (revision 1, source checked 26 Oct 2026, 14:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/containerd/containerd 1.4.3, 1.3.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/containerd/containerd: affected < 1.3.9; >= 1.4.0, < 1.4.3; fixed in 1.3.9, 1.4.3

## Suggested inspection (read-only)
- Go github.com/containerd/containerd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/containerd/containerd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-36xw-fx78-c5r4 (GitHub-reviewed advisory GHSA-36xw-fx78-c5r4 lists affected ranges: Go github.com/containerd/containerd >=0 =1.4.0 <1.4.3)

Commands are suggestions: review each one before running it.

Loading voting…