Privilege Escalation in Channelmgnt plug-in for Sopel
CVE-2020-15251GHSA-j257-jfvv-h3x5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sopel-plugins-channelmgnt 1.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sopel-plugins-channelmgnt
- Affected
- < 1.0.3
- Fixed in
- 1.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j257-jfvv-h3x5 lists affected ranges: PyPI sopel-plugins-channelmgnt >=0 <1.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:N/SI:H/SA:N · score source
- EPSS
- CVE-2020-15251: 1.45% estimated exploitation activity in the next 30 days; percentile 73.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Malicious users are able to op/voice and take over a channel
Patches On version 1.0.3
Workarounds Disable channelmgnt
References https://phab.bots.miraheze.wiki/T117
For more information If you have any questions or comments about this advisory: * Email us at staff(at)mirahezebots(dot)org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-j257-jfvv-h3x5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-15251 Advisory: Privilege Escalation in Channelmgnt plug-in for Sopel IDs: CVE-2020-15251, GHSA-j257-jfvv-h3x5 Record: https://patchnext.com/advisories/cve-2020-15251 (revision 2, source checked 25 Oct 2026, 02:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sopel-plugins-channelmgnt 1.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sopel-plugins-channelmgnt: affected < 1.0.3; fixed in 1.0.3 ## Suggested inspection (read-only) - `python -m pip show sopel-plugins-channelmgnt`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sopel-plugins-channelmgnt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j257-jfvv-h3x5 (OSV record GHSA-j257-jfvv-h3x5 lists affected ranges: PyPI sopel-plugins-channelmgnt >=0 <1.0.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…