Skip to content

← Actionable
Low, CVSS 2.8

Stored XSS by authenticated backend user with access to upload files

CVE-2020-15249GHSA-fx3v-553x-3c4q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/backend 1.0.469), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2020-15249: 0.46% estimated exploitation activity in the next 30 days; percentile 40.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Backend users with access to upload files were permitted to upload SVG files without any sanitization applied to the uploaded files. Since SVG files support being parsed as HTML by browsers, this means that they could theoretically upload Javascript that would be executed on a path under the website's domain (i.e. /storage/app/media/evil.svg), but they would have to convince their target to visit that location directly in the target's browser as the backend does not display SVGs inline anywhere, SVGs are only displayed as image resources in the backend and are thus unable to be executed. Patches Issue has been patched in Build 469 (v1.0.469) & v1.1.0. Workarounds Apply https://github.com/octobercms/library/commit/80aab47f044a2660aa352450f55137598f362aa4 to your installation manually if unable to upgrade to Build 469 or v1.1.0. References Reported by Hoan Hoang For more information If you have any questions or comments about this advisory: Email us at hello@octobercms.com…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fx3v-553x-3c4q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15249

Advisory: Stored XSS by authenticated backend user with access to upload files
IDs: CVE-2020-15249, GHSA-fx3v-553x-3c4q
Record: https://patchnext.com/advisories/cve-2020-15249 (revision 1, source checked 26 Oct 2026, 13:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: october/backend 1.0.469. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist october/backend: affected >= 1.0.319, < 1.0.469; fixed in 1.0.469

## Suggested inspection (read-only)
- Packagist october/backend: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on october/backend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fx3v-553x-3c4q (GitHub-reviewed advisory GHSA-fx3v-553x-3c4q lists affected ranges: Packagist october/backend >=1.0.319 <1.0.469)

Commands are suggestions: review each one before running it.

Loading voting…