Skip to content

← Actionable
Medium, CVSS 4.7

Cross-Site Scripting in ternary conditional operator

CVE-2020-15241GHSA-7733-hjv6-4h47

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-core 9.5.6, 8.7.25; typo3/cms 9.5.6, 8.7.25; typo3fluid/fluid 2.6.1, 2.5.5, 2.4.1, 2.3.5, 2.2.1, 2.1.4, 2.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist typo3/cms-core

    Affected
    >= 8.0.0, < 8.7.25>= 9.0.0, < 9.5.6
    Fixed in
    8.7.25, 9.5.6
  • Packagist typo3/cms

    Affected
    >= 8.0.0, < 8.7.25>= 9.0.0, < 9.5.6
    Fixed in
    8.7.25, 9.5.6
  • Packagist typo3fluid/fluid

    Affected
    >= 2.0.0, < 2.0.5>= 2.1.0, < 2.1.4>= 2.2.0, < 2.2.1>= 2.3.0, < 2.3.5>= 2.4.0, < 2.4.1>= 2.5.0, < 2.5.5>= 2.6.0, < 2.6.1
    Fixed in
    2.4.1, 2.5.5, 2.3.5, 2.0.5, 2.6.1, 2.1.4, 2.2.1

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-7733-hjv6-4h47 lists affected ranges: Packagist typo3fluid/fluid >=2.0.0 =2.1.0 =2.2.0 =2.3.0 =2.4.0 =2.5.0 =2.6.0 =8.0.0 =9.0.0 =8.0.0 =9.0.0 <9.5.6

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2020-15241: 0.97% estimated exploitation activity in the next 30 days; percentile 61.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Meta CVSS: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N/E:F/RL:O/RC:C(5.0) CWE-79 --- :informationsource: &nbsp;This vulnerability has been fixed in May 2019 already, CVE and GHSA were assigned later in October 2020 --- Problem It has been discovered that the Fluid Engine (package typo3fluid/fluid) is vulnerable to cross-site scripting when making use of the ternary conditional operator in templates like the following. Solution Update to versions 2.0.5, 2.1.4, 2.2.1, 2.3.5, 2.4.1, 2.5.5 or 2.6.1 of this typo3fluid/fluid package that fix the problem described. Updated versions of this package are bundled in following TYPO3 (typo3/cms-core) releases: TYPO3 v8.7.25 (using typo3fluid/fluid v2.5.5) TYPO3 v9.5.6 (using typo3fluid/fluid v2.6.1) Credits Thanks to Bill Dagou who reported this issue and to TYPO3 core merger Claus Due who fixed the issue. References TYPO3-CORE-SA-2019-013

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7733-hjv6-4h47

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15241

Advisory: Cross-Site Scripting in ternary conditional operator
IDs: CVE-2020-15241, GHSA-7733-hjv6-4h47
Record: https://patchnext.com/advisories/cve-2020-15241 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typo3/cms-core 9.5.6, 8.7.25; typo3/cms 9.5.6, 8.7.25; typo3fluid/fluid 2.6.1, 2.5.5, 2.4.1, 2.3.5, 2.2.1, 2.1.4, 2.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist typo3/cms-core: affected >= 8.0.0, < 8.7.25; >= 9.0.0, < 9.5.6; fixed in 8.7.25, 9.5.6
- Packagist typo3/cms: affected >= 8.0.0, < 8.7.25; >= 9.0.0, < 9.5.6; fixed in 8.7.25, 9.5.6
- Packagist typo3fluid/fluid: affected >= 2.0.0, < 2.0.5; >= 2.1.0, < 2.1.4; >= 2.2.0, < 2.2.1; >= 2.3.0, < 2.3.5; >= 2.4.0, < 2.4.1; >= 2.5.0, < 2.5.5; >= 2.6.0, < 2.6.1; fixed in 2.4.1, 2.5.5, 2.3.5, 2.0.5, 2.6.1, 2.1.4, 2.2.1

## Suggested inspection (read-only)
- Packagist typo3/cms-core: check the installed version with your package manager.
- Packagist typo3/cms: check the installed version with your package manager.
- Packagist typo3fluid/fluid: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typo3/cms-core, typo3/cms, typo3fluid/fluid.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7733-hjv6-4h47 (GitHub-reviewed advisory GHSA-7733-hjv6-4h47 lists affected ranges: Packagist typo3fluid/fluid >=2.0.0 =2.1.0 =2.2.0 =2.3.0 =2.4.0 =2.5.0 =2.6.0 =8.0.0 =9.0.0 =8.0.0 =9.0.0 <9.5.6)

Commands are suggestions: review each one before running it.

Loading voting…