Skip to content

← Actionable
Low, CVSS 2.3amended

Directory Traversal vulnerability in GET/PUT allows attackers to Disclose Information or Write Files via a crafted GET/PUT request

CVE-2020-15239GHSA-hwv5-w8gm-fq9f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (xmpp-http-upload 0.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N · score source
EPSS
  • CVE-2020-15239: 1.87% estimated exploitation activity in the next 30 days; percentile 79.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Information Disclosure When the GET method is attacked, attackers can read files which have a .data suffix and which are accompanied by a JSON file with the .meta suffix. This can lead to Information Disclosure and in some shared-hosting scenarios also to circumvention of authentication or other limitations on the outbound (GET) traffic. For example, in a scenario where a single server has multiple instances of the application running (with separate DATAROOT settings), an attacker who has knowledge about the directory structure is able to read files from any other instance to which the process has read access. If instances have individual authentication (for example, HTTP authentication via a reverse proxy, source IP based filtering) or other restrictions (such as quotas), attackers may circumvent those limits in such a scenario by using the Directory Traversal to retrieve data from the other instances. File Write If the associated XMPP server (or anyone knowing the SECRETKEY)…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hwv5-w8gm-fq9f

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hwv5-w8gm-fq9f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15239

Advisory: Directory Traversal vulnerability in GET/PUT allows attackers to Disclose Information or Write Files via a crafted GET/PUT request
IDs: CVE-2020-15239, GHSA-hwv5-w8gm-fq9f
Record: https://patchnext.com/advisories/cve-2020-15239 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: xmpp-http-upload 0.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI xmpp-http-upload: affected < 0.4.0; fixed in 0.4.0

## Suggested inspection (read-only)
- `python -m pip show xmpp-http-upload`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on xmpp-http-upload.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hwv5-w8gm-fq9f (OSV record GHSA-hwv5-w8gm-fq9f lists affected ranges: PyPI xmpp-http-upload >=0 <0.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-hwv5-w8gm-fq9f (GitHub-reviewed advisory GHSA-hwv5-w8gm-fq9f lists affected ranges: PyPI xmpp-http-upload >=0 <0.4.0)

Commands are suggestions: review each one before running it.

Loading voting…