Skip to content

← Actionable
Medium, CVSS 5.9

Possible timing attack in derivation_endpoint

CVE-2020-15237GHSA-5jjv-x4fq-qjwp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shrine 3.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems shrine

    Affected
    < 3.3.0
    Fixed in
    3.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2020-15237: 1.01% estimated exploitation activity in the next 30 days; percentile 63.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When using the derivationendpoint plugin, it's possible for the attacker to use a timing attack to guess the signature of the derivation URL. Patches The problem has been fixed by comparing sent and calculated signature in constant time, using Rack::Utils.securecompare. Users using the derivationendpoint plugin are urged to upgrade to Shrine 3.3.0 or greater. Workarounds Users of older Shrine versions can apply the following monkey-patch after loading the derivationendpoint plugin: References You can read more about timing attacks here.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5jjv-x4fq-qjwp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15237

Advisory: Possible timing attack in derivation_endpoint
IDs: CVE-2020-15237, GHSA-5jjv-x4fq-qjwp
Record: https://patchnext.com/advisories/cve-2020-15237 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shrine 3.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems shrine: affected < 3.3.0; fixed in 3.3.0

## Suggested inspection (read-only)
- RubyGems shrine: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shrine.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5jjv-x4fq-qjwp (GitHub-reviewed advisory GHSA-5jjv-x4fq-qjwp lists affected ranges: RubyGems shrine >=0 <3.3.0)

Commands are suggestions: review each one before running it.

Loading voting…