Skip to content

← Actionable
Low, CVSS 3.5amended

Environment Variable Injection in GitHub Actions

CVE-2020-15228GHSA-mfwh-5m23-j46w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@actions/core 1.2.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N
EPSS
  • CVE-2020-15228: 1.49% estimated exploitation activity in the next 30 days; percentile 74.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The @actions/core npm module addPath and exportVariable functions communicate with the Actions Runner over stdout by generating a string in a specific format. Workflows that log untrusted data to stdout may invoke these commands, resulting in the path or environment variables being modified without the intention of the workflow or action author. Patches The runner will release an update that disables the set-env and add-path workflow commands in the near future. For now, users should upgrade to @actions/core v1.2.6 or later, and replace any instance of the set-env or add-path commands in their workflows with the new Environment File Syntax. Workflows and actions using the old commands or older versions of the toolkit will start to warn, then error out during workflow execution. Workarounds None, it is strongly suggested that you upgrade as soon as possible. For more information If you have any questions or comments about this advisory: Open an issue in Actions Toolkit

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mfwh-5m23-j46w

  2. Revision 1 · created ·

    Published from osv record GHSA-mfwh-5m23-j46w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15228

Advisory: Environment Variable Injection in GitHub Actions
IDs: CVE-2020-15228, GHSA-mfwh-5m23-j46w
Record: https://patchnext.com/advisories/cve-2020-15228 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @actions/core 1.2.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @actions/core: affected < 1.2.6; fixed in 1.2.6

## Suggested inspection (read-only)
- `npm ls @actions/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @actions/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mfwh-5m23-j46w (OSV record GHSA-mfwh-5m23-j46w lists affected ranges: npm @actions/core >=0 <1.2.6 (fixed))
- Verified: https://github.com/advisories/GHSA-mfwh-5m23-j46w (GitHub-reviewed advisory GHSA-mfwh-5m23-j46w lists affected ranges: npm @actions/core >=0 <1.2.6)

Commands are suggestions: review each one before running it.

Loading voting…