Skip to content

← Actionable
Critical, CVSS 9.1amended

Out of bounds write in tensorflow-lite

CVE-2020-15214GHSA-p2cq-cprg-frvm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.3.1, 2.2.1; tensorflow-gpu 2.3.1, 2.2.1; tensorflow-cpu 2.3.1, 2.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tensorflow

    Affected
    >= 2.2.0, <= 2.2.0>= 2.3.0, <= 2.3.0
    Fixed in
    2.3.1, 2.2.1
  • PyPI tensorflow-gpu

    Affected
    >= 2.2.0, <= 2.2.0>= 2.3.0, <= 2.3.0
    Fixed in
    2.3.1, 2.2.1
  • PyPI tensorflow-cpu

    Affected
    >= 2.2.0, <= 2.2.0>= 2.3.0, <= 2.3.0
    Fixed in
    2.3.1, 2.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:H/SC:L/SI:L/SA:H · score source
EPSS
  • CVE-2020-15214: 0.67% estimated exploitation activity in the next 30 days; percentile 52.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In TensorFlow Lite models using segment sum can trigger a write out bounds / segmentation fault if the segment ids are not sorted. Code assumes that the segment ids are in increasing order, using the last element of the tensor holding them to determine the dimensionality of output tensor: https://github.com/tensorflow/tensorflow/blob/0e68f4d3295eb0281a517c3662f6698992b7b2cf/tensorflow/lite/kernels/segmentsum.cc#L39-L44 This results in allocating insufficient memory for the output tensor and in a write outside the bounds of the output array: https://github.com/tensorflow/tensorflow/blob/0e68f4d3295eb0281a517c3662f6698992b7b2cf/tensorflow/lite/kernels/internal/reference/referenceops.h#L2625-L2631 This usually results in a segmentation fault, but depending on runtime conditions it can provide for a write gadget to be used in future memory corruption-based exploits. Patches We have patched the issue in 204945b and will release patch releases for all affected versions. We recommend…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-p2cq-cprg-frvm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-p2cq-cprg-frvm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15214

Advisory: Out of bounds write in tensorflow-lite
IDs: CVE-2020-15214, GHSA-p2cq-cprg-frvm
Record: https://patchnext.com/advisories/cve-2020-15214 (revision 3, source checked 26 Oct 2026, 13:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.3.1, 2.2.1; tensorflow-gpu 2.3.1, 2.2.1; tensorflow-cpu 2.3.1, 2.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected >= 2.2.0, <= 2.2.0; >= 2.3.0, <= 2.3.0; fixed in 2.3.1, 2.2.1
- PyPI tensorflow-gpu: affected >= 2.2.0, <= 2.2.0; >= 2.3.0, <= 2.3.0; fixed in 2.3.1, 2.2.1
- PyPI tensorflow-cpu: affected >= 2.2.0, <= 2.2.0; >= 2.3.0, <= 2.3.0; fixed in 2.3.1, 2.2.1

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p2cq-cprg-frvm (OSV record GHSA-p2cq-cprg-frvm lists affected ranges: PyPI tensorflow >=2.2.0 =2.3.0 =2.2.0 =2.3.0 =2.2.0 =2.3.0 <2.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-p2cq-cprg-frvm (GitHub-reviewed advisory GHSA-p2cq-cprg-frvm lists affected ranges: PyPI tensorflow >=2.2.0 =2.3.0 =2.2.0 =2.3.0 =2.2.0 =2.3.0 <=2.3.0)

Commands are suggestions: review each one before running it.

Loading voting…