Skip to content

← Actionable
High, CVSS 8.2amended

Denial of Service in Tensorflow

CVE-2020-15199GHSA-x5cp-9pcf-pp3h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.3.1; tensorflow-gpu 2.3.1; tensorflow-cpu 2.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2020-15199: 0.81% estimated exploitation activity in the next 30 days; percentile 57.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The RaggedCountSparseOutput does not validate that the input arguments form a valid ragged tensor. In particular, there is no validation that the splits tensor has the minimum required number of elements. Code uses this quantity to initialize a different data structure: https://github.com/tensorflow/tensorflow/blob/0e68f4d3295eb0281a517c3662f6698992b7b2cf/tensorflow/core/kernels/countops.cc#L241-L244 Since BatchedMap is equivalent to a vector, it needs to have at least one element to not be nullptr. If user passes a splits tensor that is empty or has exactly one element, we get a SIGABRT signal raised by the operating system. Patches We have patched the issue in 3cbb917b4714766030b28eba9fb41bb97ce9ee02 and will release a patch release. We recommend users to upgrade to TensorFlow 2.3.1. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability is a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x5cp-9pcf-pp3h

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-x5cp-9pcf-pp3h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15199

Advisory: Denial of Service in Tensorflow
IDs: CVE-2020-15199, GHSA-x5cp-9pcf-pp3h
Record: https://patchnext.com/advisories/cve-2020-15199 (revision 3, source checked 26 Oct 2026, 13:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.3.1; tensorflow-gpu 2.3.1; tensorflow-cpu 2.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected >= 2.3.0, <= 2.3.0; fixed in 2.3.1
- PyPI tensorflow-gpu: affected >= 2.3.0, <= 2.3.0; fixed in 2.3.1
- PyPI tensorflow-cpu: affected >= 2.3.0, <= 2.3.0; fixed in 2.3.1

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x5cp-9pcf-pp3h (OSV record GHSA-x5cp-9pcf-pp3h lists affected ranges: PyPI tensorflow >=2.3.0 =2.3.0 =2.3.0 <2.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-x5cp-9pcf-pp3h (GitHub-reviewed advisory GHSA-x5cp-9pcf-pp3h lists affected ranges: PyPI tensorflow >=2.3.0 =2.3.0 =2.3.0 <=2.3.0)

Commands are suggestions: review each one before running it.

Loading voting…