Skip to content

← Actionable
Medium, CVSS 5.8amended

Heap buffer overflow in Tensorflow

CVE-2020-15195GHSA-63xm-rx5p-xvqr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.3.1, 2.2.1, 2.1.2, 2.0.3, 1.15.4; tensorflow-gpu 2.3.1, 2.2.1, 2.1.2, 2.0.3, 1.15.4; tensorflow-cpu 2.3.1, 2.2.1, 2.1.2, 2.0.3, 1.15.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tensorflow

    Affected
    < 1.15.4>= 2.0.0, < 2.0.3>= 2.1.0, < 2.1.2>= 2.2.0, <= 2.2.0>= 2.3.0, <= 2.3.0
    Fixed in
    2.0.3, 2.1.2, 1.15.4, 2.3.1, 2.2.1
  • PyPI tensorflow-gpu

    Affected
    < 1.15.4>= 2.0.0, < 2.0.3>= 2.1.0, < 2.1.2>= 2.2.0, <= 2.2.0>= 2.3.0, <= 2.3.0
    Fixed in
    2.0.3, 2.1.2, 1.15.4, 2.3.1, 2.2.1
  • PyPI tensorflow-cpu

    Affected
    < 1.15.4>= 2.0.0, < 2.0.3>= 2.1.0, < 2.1.2>= 2.2.0, <= 2.2.0>= 2.3.0, <= 2.3.0
    Fixed in
    2.0.3, 2.1.2, 1.15.4, 2.3.1, 2.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2020-15195: 0.95% estimated exploitation activity in the next 30 days; percentile 61.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The implementation of SparseFillEmptyRowsGrad uses a double indexing pattern: https://github.com/tensorflow/tensorflow/blob/0e68f4d3295eb0281a517c3662f6698992b7b2cf/tensorflow/core/kernels/sparsefillemptyrowsop.cc#L263-L269 It is possible for reverseindexmap(i) to be an index outside of bounds of gradvalues, thus resulting in a heap buffer overflow. Patches We have patched the issue in 390611e0d45c5793c7066110af37c8514e6a6c54 and will release a patch release for all affected versions. We recommend users to upgrade to TensorFlow 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability has been reported by members of the Aivul Team from Qihoo 360.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-63xm-rx5p-xvqr

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-63xm-rx5p-xvqr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15195

Advisory: Heap buffer overflow in Tensorflow
IDs: CVE-2020-15195, GHSA-63xm-rx5p-xvqr
Record: https://patchnext.com/advisories/cve-2020-15195 (revision 3, source checked 26 Oct 2026, 13:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.3.1, 2.2.1, 2.1.2, 2.0.3, 1.15.4; tensorflow-gpu 2.3.1, 2.2.1, 2.1.2, 2.0.3, 1.15.4; tensorflow-cpu 2.3.1, 2.2.1, 2.1.2, 2.0.3, 1.15.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected < 1.15.4; >= 2.0.0, < 2.0.3; >= 2.1.0, < 2.1.2; >= 2.2.0, <= 2.2.0; >= 2.3.0, <= 2.3.0; fixed in 2.0.3, 2.1.2, 1.15.4, 2.3.1, 2.2.1
- PyPI tensorflow-gpu: affected < 1.15.4; >= 2.0.0, < 2.0.3; >= 2.1.0, < 2.1.2; >= 2.2.0, <= 2.2.0; >= 2.3.0, <= 2.3.0; fixed in 2.0.3, 2.1.2, 1.15.4, 2.3.1, 2.2.1
- PyPI tensorflow-cpu: affected < 1.15.4; >= 2.0.0, < 2.0.3; >= 2.1.0, < 2.1.2; >= 2.2.0, <= 2.2.0; >= 2.3.0, <= 2.3.0; fixed in 2.0.3, 2.1.2, 1.15.4, 2.3.1, 2.2.1

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-63xm-rx5p-xvqr (OSV record GHSA-63xm-rx5p-xvqr lists affected ranges: PyPI tensorflow >=0 =2.0.0 =2.1.0 =2.2.0 =2.3.0 =0 =2.0.0 =2.1.0 =2.2.0 =2.3.0 =0 =2.0.0 =2.1.0 =2.2.0 =2.3.0 <2.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-63xm-rx5p-xvqr (GitHub-reviewed advisory GHSA-63xm-rx5p-xvqr lists affected ranges: PyPI tensorflow >=0 =2.0.0 =2.1.0 =2.2.0 =2.3.0 =0 =2.0.0 =2.1.0 =2.2.0 =2.3.0 =0 =2.0.0 =2.1.0 =2.2.0 =2.3.0 <=2.3.0)

Commands are suggestions: review each one before running it.

Loading voting…