Skip to content

← Actionable
High, CVSS 7.1amended

Memory corruption in Tensorflow

CVE-2020-15193GHSA-rjjg-hgv6-h69v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.3.1, 2.2.1; tensorflow-gpu 2.3.1, 2.2.1; tensorflow-cpu 2.3.1, 2.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tensorflow

    Affected
    >= 2.2.0, <= 2.2.0>= 2.3.0, <= 2.3.0
    Fixed in
    2.3.1, 2.2.1
  • PyPI tensorflow-gpu

    Affected
    >= 2.2.0, <= 2.2.0>= 2.3.0, <= 2.3.0
    Fixed in
    2.3.1, 2.2.1
  • PyPI tensorflow-cpu

    Affected
    >= 2.2.0, <= 2.2.0>= 2.3.0, <= 2.3.0
    Fixed in
    2.3.1, 2.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2020-15193: 0.83% estimated exploitation activity in the next 30 days; percentile 57.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The implementation of dlpack.todlpack can be made to use uninitialized memory resulting in further memory corruption. This is because the pybind11 glue code assumes that the argument is a tensor: https://github.com/tensorflow/tensorflow/blob/0e68f4d3295eb0281a517c3662f6698992b7b2cf/tensorflow/python/tfewrapper.cc#L1361 However, there is nothing stopping users from passing in a Python object instead of a tensor. The uninitialized memory address is due to a reinterpretcast https://github.com/tensorflow/tensorflow/blob/0e68f4d3295eb0281a517c3662f6698992b7b2cf/tensorflow/python/eager/pywraptensor.cc#L848-L850 Since the PyObject is a Python object, not a TensorFlow Tensor, the cast to EagerTensor fails. Patches We have patched the issue in 22e07fb204386768e5bcbea563641ea11f96ceb8 and will release a patch release for all affected versions. We recommend users to upgrade to TensorFlow 2.2.1 or 2.3.1. For more information Please consult our security guide for more information regarding…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rjjg-hgv6-h69v

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-rjjg-hgv6-h69v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15193

Advisory: Memory corruption in Tensorflow
IDs: CVE-2020-15193, GHSA-rjjg-hgv6-h69v
Record: https://patchnext.com/advisories/cve-2020-15193 (revision 3, source checked 26 Oct 2026, 13:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.3.1, 2.2.1; tensorflow-gpu 2.3.1, 2.2.1; tensorflow-cpu 2.3.1, 2.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected >= 2.2.0, <= 2.2.0; >= 2.3.0, <= 2.3.0; fixed in 2.3.1, 2.2.1
- PyPI tensorflow-gpu: affected >= 2.2.0, <= 2.2.0; >= 2.3.0, <= 2.3.0; fixed in 2.3.1, 2.2.1
- PyPI tensorflow-cpu: affected >= 2.2.0, <= 2.2.0; >= 2.3.0, <= 2.3.0; fixed in 2.3.1, 2.2.1

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rjjg-hgv6-h69v (OSV record GHSA-rjjg-hgv6-h69v lists affected ranges: PyPI tensorflow >=2.2.0 =2.3.0 =2.2.0 =2.3.0 =2.2.0 =2.3.0 <2.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-rjjg-hgv6-h69v (GitHub-reviewed advisory GHSA-rjjg-hgv6-h69v lists affected ranges: PyPI tensorflow >=2.2.0 =2.3.0 =2.2.0 =2.3.0 =2.2.0 =2.3.0 <=2.3.0)

Commands are suggestions: review each one before running it.

Loading voting…