Unpreventable top-level navigation
CVE-2020-15174GHSA-2q4g-w47c-4674
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron 10.0.1, 9.3.0, 8.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm electron
- Affected
- >= 8.0.0-beta.0, < 8.5.1>= 9.0.0-beta.0, < 9.3.0>= 10.0.0-beta.0, < 10.0.1
- Fixed in
- 10.0.1, 9.3.0, 8.5.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2q4g-w47c-4674 lists affected ranges: npm electron >=8.0.0-beta.0 =9.0.0-beta.0 =10.0.0-beta.0 <10.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2q4g-w47c-4674 lists affected ranges: npm electron >=8.0.0-beta.0 =9.0.0-beta.0 =10.0.0-beta.0 <10.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:L
- EPSS
- CVE-2020-15174: 1.35% estimated exploitation activity in the next 30 days; percentile 71.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The will-navigate event that apps use to prevent navigations to unexpected destinations as per our security recommendations can be bypassed when a sub-frame performs a top-frame navigation across sites. Patches 11.0.0-beta.1 10.0.1 9.3.0 8.5.1 Workarounds Sandbox all your iframes using the sandbox attribute. This will prevent them creating top-frame navigations and is good practice anyway. For more information If you have any questions or comments about this advisory: Email us at security@electronjs.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2q4g-w47c-4674
- Revision 1 · created ·
Published from osv record GHSA-2q4g-w47c-4674
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-15174 Advisory: Unpreventable top-level navigation IDs: CVE-2020-15174, GHSA-2q4g-w47c-4674 Record: https://patchnext.com/advisories/cve-2020-15174 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: electron 10.0.1, 9.3.0, 8.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm electron: affected >= 8.0.0-beta.0, < 8.5.1; >= 9.0.0-beta.0, < 9.3.0; >= 10.0.0-beta.0, < 10.0.1; fixed in 10.0.1, 9.3.0, 8.5.1 ## Suggested inspection (read-only) - `npm ls electron --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on electron. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2q4g-w47c-4674 (OSV record GHSA-2q4g-w47c-4674 lists affected ranges: npm electron >=8.0.0-beta.0 =9.0.0-beta.0 =10.0.0-beta.0 <10.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-2q4g-w47c-4674 (GitHub-reviewed advisory GHSA-2q4g-w47c-4674 lists affected ranges: npm electron >=8.0.0-beta.0 =9.0.0-beta.0 =10.0.0-beta.0 <10.0.1) Commands are suggestions: review each one before running it.
Loading voting…