Skip to content

← Actionable
Medium, CVSS 5.4

XSS in Action View

CVE-2020-15169GHSA-cfjv-5498-mph5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (actionview 6.0.3.3, 5.2.4.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems actionview

    Affected
    >= 6.0.0.0, <= 6.0.3.2<= 5.2.4.3
    Fixed in
    5.2.4.4, 6.0.3.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
EPSS
  • CVE-2020-15169: 2.37% estimated exploitation activity in the next 30 days; percentile 83.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the t and translate helpers could be susceptible to XSS attacks. Impact When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in html, the default string is incorrectly marked as HTML-safe and not escaped. Vulnerable code may look like the following examples: Patches Patched Rails versions, 6.0.3.3 and 5.2.4.4, are available from the normal locations. The patches have also been applied to the master, 6-0-stable, and 5-2-stable branches on GitHub. If you track any of these branches, you should update to the latest. To aid users who aren’t able to upgrade immediately, we’ve provided patches for the two supported release series. They are in git-am format and consist of a single changeset. 5-2-translate-helper-xss.patch — patch for the 5.2 release series…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cfjv-5498-mph5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15169

Advisory: XSS in Action View
IDs: CVE-2020-15169, GHSA-cfjv-5498-mph5
Record: https://patchnext.com/advisories/cve-2020-15169 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: actionview 6.0.3.3, 5.2.4.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems actionview: affected >= 6.0.0.0, <= 6.0.3.2; <= 5.2.4.3; fixed in 5.2.4.4, 6.0.3.3

## Suggested inspection (read-only)
- RubyGems actionview: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on actionview.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cfjv-5498-mph5 (GitHub-reviewed advisory GHSA-cfjv-5498-mph5 lists affected ranges: RubyGems actionview >=6.0.0.0 =0 <=5.2.4.3)

Commands are suggestions: review each one before running it.

Loading voting…