Invalid root may become trusted root in The Update Framework (TUF)
CVE-2020-15163GHSA-f8mr-jv2c-v8mg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tuf 0.12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tuf
- Affected
- < 0.12.0
- Fixed in
- 0.12.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f8mr-jv2c-v8mg lists affected ranges: PyPI tuf >=0 <0.12.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f8mr-jv2c-v8mg lists affected ranges: PyPI tuf >=0 <0.12.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N · score source
- EPSS
- CVE-2020-15163: 0.67% estimated exploitation activity in the next 30 days; percentile 52.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Python TUF reference implementation tuf<0.12 will incorrectly trust a previously downloaded root metadata file which failed verification at download time. This allows an attacker who is able to serve multiple new versions of root metadata (i.e. by a man-in-the-middle attack) culminating in a version which has not been correctly signed to control the trust chain for future updates. While investigating the reported vulnerability, we discovered that the detailed client workflow was not fully implemented. Specifically, for step 1.3 the newly downloaded root metadata was not being verified with a threshold of keys specified in the new root metadata file. This missing step of the client workflow has been implemented in PR #1101, which is included in v0.14.0 of tuf. Patches A fix, is available in version 0.12 and newer. Workarounds No workarounds are known for this issue. References Pull request resolving the invalid root becoming trusted issue PR 885 Pull request implementing…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-f8mr-jv2c-v8mg
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-f8mr-jv2c-v8mg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-15163 Advisory: Invalid root may become trusted root in The Update Framework (TUF) IDs: CVE-2020-15163, GHSA-f8mr-jv2c-v8mg Record: https://patchnext.com/advisories/cve-2020-15163 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tuf 0.12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tuf: affected < 0.12.0; fixed in 0.12.0 ## Suggested inspection (read-only) - `python -m pip show tuf`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tuf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f8mr-jv2c-v8mg (OSV record GHSA-f8mr-jv2c-v8mg lists affected ranges: PyPI tuf >=0 <0.12.0 (fixed)) - Verified: https://github.com/advisories/GHSA-f8mr-jv2c-v8mg (GitHub-reviewed advisory GHSA-f8mr-jv2c-v8mg lists affected ranges: PyPI tuf >=0 <0.12.0) Commands are suggestions: review each one before running it.
Loading voting…