XSS due to lack of CSRF validation for replying/publishing
CVE-2020-15156GHSA-43m5-c88r-cjvv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nodebb-plugin-blog-comments 0.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nodebb-plugin-blog-comments
- Affected
- < 0.7.0
- Fixed in
- 0.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-43m5-c88r-cjvv lists affected ranges: npm nodebb-plugin-blog-comments >=0 <0.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-43m5-c88r-cjvv lists affected ranges: npm nodebb-plugin-blog-comments >=0 <0.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2020-15156: 0.61% estimated exploitation activity in the next 30 days; percentile 49.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Due to lack of CSRF validation, a logged in user is potentially vulnerable to an XSS attack which could allow a third party to post on their behalf on the forum. Patches Upgrade to the latest version v0.7.0 Workarounds You can cherry-pick the following commit: https://github.com/psychobunny/nodebb-plugin-blog-comments/commit/cf43beedb05131937ef46f365ab0a0c6fa6ac618 References Visit https://community.nodebb.org if you have any questions about this issue or on how to patch / upgrade your instance.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-43m5-c88r-cjvv
- Revision 1 · created ·
Published from osv record GHSA-43m5-c88r-cjvv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-15156 Advisory: XSS due to lack of CSRF validation for replying/publishing IDs: CVE-2020-15156, GHSA-43m5-c88r-cjvv Record: https://patchnext.com/advisories/cve-2020-15156 (revision 2, source checked 26 Oct 2026, 12:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nodebb-plugin-blog-comments 0.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nodebb-plugin-blog-comments: affected < 0.7.0; fixed in 0.7.0 ## Suggested inspection (read-only) - `npm ls nodebb-plugin-blog-comments --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nodebb-plugin-blog-comments. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-43m5-c88r-cjvv (OSV record GHSA-43m5-c88r-cjvv lists affected ranges: npm nodebb-plugin-blog-comments >=0 <0.7.0 (fixed)) - Verified: https://github.com/advisories/GHSA-43m5-c88r-cjvv (GitHub-reviewed advisory GHSA-43m5-c88r-cjvv lists affected ranges: npm nodebb-plugin-blog-comments >=0 <0.7.0) Commands are suggestions: review each one before running it.
Loading voting…