Server-Side Request Forgery in ftp-srv
CVE-2020-15152GHSA-jw37-5gqr-cf9j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ftp-srv 4.3.4, 3.1.2, 2.19.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ftp-srv
- Affected
- >= 1.0.0, < 2.19.6>= 3.0.0, < 3.1.2>= 4.0.0, < 4.3.4
- Fixed in
- 4.3.4, 3.1.2, 2.19.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jw37-5gqr-cf9j lists affected ranges: npm ftp-srv >=1.0.0 =3.0.0 =4.0.0 <4.3.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jw37-5gqr-cf9j lists affected ranges: npm ftp-srv >=1.0.0 =3.0.0 =4.0.0 <4.3.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2020-15152: 1.86% estimated exploitation activity in the next 30 days; percentile 79.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Background The FTP protocol creates two connections, one for commands and one for transferring data. This second data connection can be created in two ways, on the server by sending the PASV command, or on the client by sending the PORT command. The PORT command sends the IP and port for the server to connect to the client with. Issue Since the client can send an arbitrary IP with the PORT command, this can be used to cause the server to make a connection elsewhere. Patches fix: disallow PORT connections to alternate hosts: e449e75219d918c400dec65b4b0759f60476abca Deprecation notices have been published for older versions. Workarounds Blacklisting the FTP Command PORT will prevent the server from exposing this behaviour through active connections until a fix is applied. References https://www.npmjs.com/advisories/1445 Credits Thank you to; @trs for fixing it @andreeleuterio for reporting it to us for an anonymous user (Vincent) through the NPM platform @quiquelhappy for bringing it…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jw37-5gqr-cf9j
- Revision 1 · created ·
Published from osv record GHSA-jw37-5gqr-cf9j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-15152 Advisory: Server-Side Request Forgery in ftp-srv IDs: CVE-2020-15152, GHSA-jw37-5gqr-cf9j Record: https://patchnext.com/advisories/cve-2020-15152 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ftp-srv 4.3.4, 3.1.2, 2.19.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ftp-srv: affected >= 1.0.0, < 2.19.6; >= 3.0.0, < 3.1.2; >= 4.0.0, < 4.3.4; fixed in 4.3.4, 3.1.2, 2.19.6 ## Suggested inspection (read-only) - `npm ls ftp-srv --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ftp-srv. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jw37-5gqr-cf9j (OSV record GHSA-jw37-5gqr-cf9j lists affected ranges: npm ftp-srv >=1.0.0 =3.0.0 =4.0.0 <4.3.4 (fixed)) - Verified: https://github.com/advisories/GHSA-jw37-5gqr-cf9j (GitHub-reviewed advisory GHSA-jw37-5gqr-cf9j lists affected ranges: npm ftp-srv >=1.0.0 =3.0.0 =4.0.0 <4.3.4) Commands are suggestions: review each one before running it.
Loading voting…