Unsafe deserialization in Yii 2
CVE-2020-15148GHSA-699q-wcff-g9mj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (yiisoft/yii2 2.0.38), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist yiisoft/yii2
- Affected
- < 2.0.38
- Fixed in
- 2.0.38
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-699q-wcff-g9mj lists affected ranges: Packagist yiisoft/yii2 >=0 <2.0.38
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:H
- EPSS
- CVE-2020-15148: 77.54% estimated exploitation activity in the next 30 days; percentile 99.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Remote code execution in case application calls unserialize() on user input containing specially crafted string. Patches 2.0.38 Workarounds Add the following to BatchQueryResult.php: For more information If you have any questions or comments about this advisory, contact us through security form.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-699q-wcff-g9mj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-15148 Advisory: Unsafe deserialization in Yii 2 IDs: CVE-2020-15148, GHSA-699q-wcff-g9mj Record: https://patchnext.com/advisories/cve-2020-15148 (revision 1, source checked 26 Oct 2026, 14:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: yiisoft/yii2 2.0.38. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist yiisoft/yii2: affected < 2.0.38; fixed in 2.0.38 ## Suggested inspection (read-only) - Packagist yiisoft/yii2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on yiisoft/yii2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-699q-wcff-g9mj (GitHub-reviewed advisory GHSA-699q-wcff-g9mj lists affected ranges: Packagist yiisoft/yii2 >=0 <2.0.38) Commands are suggestions: review each one before running it.
Loading voting…