Path Traversal in openapi-python-client
CVE-2020-15141GHSA-7wgr-7666-7pwj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openapi-python-client 0.5.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.5.3
- Fixed in
- 0.5.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7wgr-7666-7pwj lists affected ranges: PyPI openapi-python-client >=0 <0.5.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7wgr-7666-7pwj lists affected ranges: PyPI openapi-python-client >=0 <0.5.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N · score source
- EPSS
- CVE-2020-15141: 1.14% estimated exploitation activity in the next 30 days; percentile 66.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Path traversal vulnerability. If a user generated a client using a maliciously crafted OpenAPI document, it is possible for generated files to be placed in arbitrary locations on disk. Giving this a CVSS score of 3.0 (Low) with CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:N/E:P/RL:U/RC:C Patches A fix is being worked on for version 0.5.3 Workarounds Inspect OpenAPI documents before generating clients for them. For more information If you have any questions or comments about this advisory: Open an issue in openapi-python-client Email us at danthony@triaxtec.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7wgr-7666-7pwj
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7wgr-7666-7pwj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-15141 Advisory: Path Traversal in openapi-python-client IDs: CVE-2020-15141, GHSA-7wgr-7666-7pwj Record: https://patchnext.com/advisories/cve-2020-15141 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openapi-python-client 0.5.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI openapi-python-client: affected < 0.5.3; fixed in 0.5.3 ## Suggested inspection (read-only) - `python -m pip show openapi-python-client`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openapi-python-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7wgr-7666-7pwj (OSV record GHSA-7wgr-7666-7pwj lists affected ranges: PyPI openapi-python-client >=0 <0.5.3 (fixed)) - Verified: https://github.com/advisories/GHSA-7wgr-7666-7pwj (GitHub-reviewed advisory GHSA-7wgr-7666-7pwj lists affected ranges: PyPI openapi-python-client >=0 <0.5.3) Commands are suggestions: review each one before running it.
Loading voting…