Cross-Site Scripting in Prism
CVE-2020-15138GHSA-wvhm-4hhf-97x9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (prismjs 1.21.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm prismjs
- Affected
- >= 1.1.0, < 1.21.0
- Fixed in
- 1.21.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wvhm-4hhf-97x9 lists affected ranges: npm prismjs >=1.1.0 <1.21.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wvhm-4hhf-97x9 lists affected ranges: npm prismjs >=1.1.0 <1.21.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L
- EPSS
- CVE-2020-15138: 2.04% estimated exploitation activity in the next 30 days; percentile 81.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism =v1.1.0 that use the Previewers plugin (=v1.10.0) or the Previewer: Easing plugin (v1.1.0 to v1.9.0). Patches This problem is patched in v1.21.0. Workarounds To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround. References The vulnerability was introduced by this commit on Sep 29, 2015 and fixed by Masato Kinugawa (#2506). For more information If you have any questions or comments about this advisory, please open an issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wvhm-4hhf-97x9
- Revision 1 · created ·
Published from osv record GHSA-wvhm-4hhf-97x9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-15138 Advisory: Cross-Site Scripting in Prism IDs: CVE-2020-15138, GHSA-wvhm-4hhf-97x9 Record: https://patchnext.com/advisories/cve-2020-15138 (revision 2, source checked 26 Oct 2026, 12:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: prismjs 1.21.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm prismjs: affected >= 1.1.0, < 1.21.0; fixed in 1.21.0 ## Suggested inspection (read-only) - `npm ls prismjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on prismjs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wvhm-4hhf-97x9 (OSV record GHSA-wvhm-4hhf-97x9 lists affected ranges: npm prismjs >=1.1.0 <1.21.0 (fixed)) - Verified: https://github.com/advisories/GHSA-wvhm-4hhf-97x9 (GitHub-reviewed advisory GHSA-wvhm-4hhf-97x9 lists affected ranges: npm prismjs >=1.1.0 <1.21.0) Commands are suggestions: review each one before running it.
Loading voting…