Skip to content

← Actionable
High, CVSS 7.5amended

False-positive validity for NFT1 genesis transactions in SLPJS

CVE-2020-15130GHSA-cc2p-4jhr-xhhx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (slpjs 0.27.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm slpjs

    Affected
    < 0.27.4
    Fixed in
    0.27.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2020-15130: 1.04% estimated exploitation activity in the next 30 days; percentile 63.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In the npm package named "slpjs", versions prior to 0.27.4 are vulnerable to false-positive validation outcomes for the NFT1 Child Genesis transaction type. A poorly implemented SLP wallet or opportunistic attacker could create a seemingly valid NFT1 child token without burning any of the NFT1 Group token type as is required by the NFT1 specification. Patches npm package "slpjs" has been patched and is published and tagged as version 0.27.4. Workarounds Upgrade to slpjs 0.27.4. References Package location: https://www.npmjs.com/package/slpjs SLP NFT1 spec: https://slp.dev/specs/slp-nft-1/#nft1-protocol-requirements Git commit hash fixing this issue: https://github.com/simpleledger/slpjs/commit/290c20e8bff13ac81459d43e54cac232b5e3456c Unit tests have been added to assist validator implementations in avoiding this bug: https://github.com/simpleledger/slp-unit-test-data/commit/8c942eacfae12686dcf1f3366321445a4fba73e7 For more information If you have any questions or comments…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cc2p-4jhr-xhhx

  2. Revision 1 · created ·

    Published from osv record GHSA-cc2p-4jhr-xhhx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15130

Advisory: False-positive validity for NFT1 genesis transactions in SLPJS
IDs: CVE-2020-15130, GHSA-cc2p-4jhr-xhhx
Record: https://patchnext.com/advisories/cve-2020-15130 (revision 2, source checked 26 Oct 2026, 12:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: slpjs 0.27.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm slpjs: affected < 0.27.4; fixed in 0.27.4

## Suggested inspection (read-only)
- `npm ls slpjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on slpjs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cc2p-4jhr-xhhx (OSV record GHSA-cc2p-4jhr-xhhx lists affected ranges: npm slpjs >=0 <0.27.4 (fixed))
- Verified: https://github.com/advisories/GHSA-cc2p-4jhr-xhhx (GitHub-reviewed advisory GHSA-cc2p-4jhr-xhhx lists affected ranges: npm slpjs >=0 <0.27.4)

Commands are suggestions: review each one before running it.

Loading voting…