Skip to content

← Actionable
High, CVSS 7.7amended

Authorization header is not sanitized in an error object in auth0

CVE-2020-15125GHSA-5jpf-pj32-xx53

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0 2.27.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm auth0

    Affected
    < 2.27.1
    Fixed in
    2.27.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2020-15125: 1.54% estimated exploitation activity in the next 30 days; percentile 74.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview Versions before and including 2.27.0 use a block list of specific keys that should be sanitized from the request object contained in the error object. When a request to Auth0 management API fails, the key for Authorization header is not sanitized and the Authorization header value can be logged exposing a bearer token. Am I affected? You are affected by this vulnerability if all of the following conditions apply: - You are using auth0 npm package - You are using a Machine to Machine application authorized to use Auth0's management API https://auth0.com/docs/flows/concepts/client-credentials How to fix that? Upgrade to version 2.27.1 Will this update impact my users? The fix provided in patch will not affect your users. Credit http://github.com/osdiab

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5jpf-pj32-xx53

  2. Revision 1 · created ·

    Published from osv record GHSA-5jpf-pj32-xx53

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15125

Advisory: Authorization header is not sanitized in an error object in auth0
IDs: CVE-2020-15125, GHSA-5jpf-pj32-xx53
Record: https://patchnext.com/advisories/cve-2020-15125 (revision 2, source checked 26 Oct 2026, 12:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: auth0 2.27.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm auth0: affected < 2.27.1; fixed in 2.27.1

## Suggested inspection (read-only)
- `npm ls auth0 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on auth0.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5jpf-pj32-xx53 (OSV record GHSA-5jpf-pj32-xx53 lists affected ranges: npm auth0 >=0 <2.27.1 (fixed))
- Verified: https://github.com/advisories/GHSA-5jpf-pj32-xx53 (GitHub-reviewed advisory GHSA-5jpf-pj32-xx53 lists affected ranges: npm auth0 >=0 <2.27.1)

Commands are suggestions: review each one before running it.

Loading voting…