Skip to content

← Actionable
Medium, CVSS 6.9amended

Authorization Bypass in I hate money

CVE-2020-15120GHSA-67j9-c52g-w2q9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ihatemoney 4.1.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2020-15120: 1.03% estimated exploitation activity in the next 30 days; percentile 63.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated member of one project can modify and delete members of another project, without knowledge of this other project's private code. This can be further exploited to access all bills of another project without knowledge of this other project's private code. With the default configuration, anybody is allowed to create a new project. An attacker can create a new project and then use it to become authenticated and exploit this flaw. As such, the exposure is similar to an unauthenticated attack, because it is trivial to become authenticated. Patches Workarounds To limit the impact, it is possible to disable public project creation by setting ALLOWPUBLICPROJECTCREATION = False in the configuration (see documentation). Existing users will still be able to exploit the flaw, but this will prevent an external attacker from creating a new project. For more information Person.query.get() and Person.query.getbyname() were mistakenly running a database join on the Project table…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-67j9-c52g-w2q9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-67j9-c52g-w2q9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15120

Advisory: Authorization Bypass in I hate money
IDs: CVE-2020-15120, GHSA-67j9-c52g-w2q9
Record: https://patchnext.com/advisories/cve-2020-15120 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ihatemoney 4.1.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ihatemoney: affected < 4.1.5; fixed in 4.1.5

## Suggested inspection (read-only)
- `python -m pip show ihatemoney`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ihatemoney.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-67j9-c52g-w2q9 (OSV record GHSA-67j9-c52g-w2q9 lists affected ranges: PyPI ihatemoney >=0 <4.1.5 (fixed))
- Verified: https://github.com/advisories/GHSA-67j9-c52g-w2q9 (GitHub-reviewed advisory GHSA-67j9-c52g-w2q9 lists affected ranges: PyPI ihatemoney >=0 <4.1.5)

Commands are suggestions: review each one before running it.

Loading voting…