Skip to content

← Actionable
Medium, CVSS 6.4amended

DOM-based XSS in auth0-lock

CVE-2020-15119GHSA-6gg3-pmm7-97xc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0-lock 11.26.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2020-15119: 0.55% estimated exploitation activity in the next 30 days; percentile 45.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview Versions before and including 11.25.1 are using dangerouslySetInnerHTML to display an informational message when used with a Passwordless or Enterprise connection. - For Passwordless connection, the value of the input (email or phone number) is displayed back to the user while waiting for verification code input. - For Enterprise connection, the value of the input (IdP Domain) from the Enterprise connection setup screen (Auth0 Dashboard) is displayed back to the user when the lock widget opens. When Passwordless or Enterprise connection is used, the application and its users might be exposed to cross-site scripting (XSS) attacks. Am I affected? You are affected by this vulnerability if all of the following conditions apply: - You are using auth0-lock - You are using Passwordless or Enterprise connection mode How to fix that? Upgrade to version 11.26.3 Will this update impact my users? The fix provided in patch will not affect your users. Credit https://github.com/mvisat

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6gg3-pmm7-97xc

  2. Revision 1 · created ·

    Published from osv record GHSA-6gg3-pmm7-97xc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15119

Advisory: DOM-based XSS in auth0-lock
IDs: CVE-2020-15119, GHSA-6gg3-pmm7-97xc
Record: https://patchnext.com/advisories/cve-2020-15119 (revision 2, source checked 26 Oct 2026, 12:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: auth0-lock 11.26.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm auth0-lock: affected <= 11.25.1; fixed in 11.26.3

## Suggested inspection (read-only)
- `npm ls auth0-lock --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on auth0-lock.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6gg3-pmm7-97xc (OSV record GHSA-6gg3-pmm7-97xc lists affected ranges: npm auth0-lock >=0 <11.26.3 (fixed))
- Verified: https://github.com/advisories/GHSA-6gg3-pmm7-97xc (GitHub-reviewed advisory GHSA-6gg3-pmm7-97xc lists affected ranges: npm auth0-lock >=0 <=11.25.1)

Commands are suggestions: review each one before running it.

Loading voting…